Probleme mit dem Queueserver - keine ein- oder ausgehenden Nachrichten

  • Hallo,


    seit dem Update haben wir hier massive Probleme mit dem Queueserver. Es gehen keinerlei Nachrichten mehr rein oder raus, die ausgehenden bleiben im Postausgang hängen und werden nicht weiter verarbeitet.


    Auch ein Neustart des Servers hilft hier nicht weiter. Ich habe soeben eine Wartung durchgeführt, anschließend lief der Queueserver wieder kurzzeitig und hat einige Elemente verarbeitet (ca. 500 eingehende und 200 ausgehende Nachrichten). Anschließend hat er jedoch wieder gestoppt und es gehen wieder keine Nachrichten ein bzw. es kommen keine neuen Nachrichten rein :(



    Im Queuestatus sind auch eine große Menge an Elementen wartend, die durch Regeln verarbeitet werden, was in sofern komisch ist, da an diesen nichts geändert wurde....


    Viele Grüße,
    Josh

  • Hallo Josh,



    hier handelt es sich um ein lokales, nicht allgemeingültiges Problem, die GREYHOUND Community dient als Plattform zum Austausch von Anwendern, "Best-Practice"-Beispielen, Ankündigungen und Dokumentationen. Klassische Support-Anfragen richten sie bitte direkt per Support-Ticket online unter https://greyhound-software.com/gcc/mytickets/action=new direkt an unseren Support.


    Vielen Dank!

  • "Bug oder Anwenderfehler


    Bestimmte Sachen erscheinen auf den ersten Blick wie ein BUG - manchmal liegt es aber auch an der Betrachtungs- und/oder Herangehensweise. Hier könnt ihr Fehler eintragen, wo ihr euch nicht sicher seid, ob es sich um einen BUG handelt."


    Schon irgendwie komisch - das System lief einwandfrei und nach einem Release (Stable keine Beta) gibt es ein Problem massiver Natur. Das ganze wird dann als individuelles Problem abgehakt und der Kunde darauf verwiesen ein Support-Ticket zu eröffnen, welches zum Bearbeitungspreis von 2,50 Euro pro Minute berechnet werden soll.


    Ich glaube so langsam ist für uns der Zeitpunkt gekommen an dem wir ernsthaft über einen Wechsel des Systems nachdenken werden...

  • Seit 3 Tagen laufen bereits 130 Live-Systeme auf Build 1325, und das bis dato fehlerfrei.


    Aus diesem Grund klassifizieren wir dieses Problem als lokales nicht allgemeingültiges Problem, das sie bis dato der einzige waren, welcher dieses Problem berichtet hat. Die Community ist kein "offizieller" Support-Kanal, gerade in einem solchen, zeitkritischen Fall sollte man daher den "offiziellen" Weg beschreiten. Aus diesem Grund habe ich darum gebeten ein entsprechendes Support-Ticket aufzugeben. Sofern der Fehler tatsächlich innerhalb Systems lokalisierbar und nicht auf ein lokales Problem zurückzuführen ist, bleibt das Support-Ticket natürlich kostenfrei.

  • So, ich hab nun nochmal etwas tiefer gegraben....


    Das wird durch eine nicht optimale my.ini verursacht, wenn der GREYHOUND in der alten Version bereits auf einer externen MySQL-Datenbank gelaufen ist.


    Hier mal zum Vergleich die aktuelle my.ini Konfiguration:


    [mysqld]
    basedir=C:\Program Files (x86)\MySQL\
    character-set-server=latin1
    datadir=C:\Program Files (x86)\MySQL\data\
    default-storage-engine=MYISAM
    enable-named-pipe
    innodb_additional_mem_pool_size=2M
    innodb_buffer_pool_size=18M
    innodb_flush_log_at_trx_commit=1
    innodb_log_buffer_size=1M
    innodb_log_file_size=10M
    innodb_thread_concurrency=8
    key_buffer_size=512M
    max_allowed_packet=32M
    max_connections=512
    myisam_max_sort_file_size=100G
    myisam_sort_buffer_size=32M
    port=3306
    query_cache_limit=1M
    query_cache_size=16M
    query_cache_type=1
    read_buffer_size=512K
    read_rnd_buffer_size=1M
    skip-external-locking
    skip-innodb
    sort_buffer_size=1M
    sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
    table_cache=256
    thread_cache_size=8
    tmp_table_size=8M


    @Guido: Kannst du das mal mit deiner aktuellen Konfiguration vergleichen?

  • Hi Jörn,


    Ich geh zumindest mal davon aus, wie gesagt im Log erscheint folgende Meldung:
    Cannot get TOCR Status for Job 0..... und das ungefähr 20 mal in einer Sekunde solange bis Greyhoundserver.exe gekillt wird (Stoppen geht nicht, bsw ist nach 20 Minuten immer noch nicht gestoppt!) Nach dem starten funktioniert es dann immer mal wieder 10-20 Minuten, dann kommt die TOCR Meldung wieder uns im Queueserver geht gar nichts mehr.


    Werde die DB nachmar mal prüfen lassen, sollten keine Fehler bei der Pruefung auftauschen mache ich wohl am besten ein Ticket auf!


    Gruß Guido

  • Ich muss gerad mal eine halbe Stunde dringend weg,
    vielleicht schaust du mal durch:
    [code=sql]
    default-character-set=latin1
    [mysqld]
    port=3306
    skip-locking
    enable-named-pipe
    max_allowed_packet=64M
    basedir="G:/Greyhound/MySQL/MySQL Server 5.1/"
    datadir="G:/Greyhound/MySQL/MySQL Server 5.1/Data/"
    default-character-set=latin1
    default-storage-engine=MYISAM
    sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
    max_connections=512
    query_cache_size=32M
    query_cache_limit=1M
    query_cache_type=1
    table_cache=256
    tmp_table_size=8M
    thread_cache_size=16
    myisam_max_sort_file_size=100G
    myisam_sort_buffer_size=16M
    key_buffer_size=512M
    read_buffer_size=256K
    read_rnd_buffer_size=512K
    sort_buffer_size=512K
    server_id=1
    log_bin="G:/GREYHOUND/MySQL/MySQL Server 5.1/Data/mysql-bin"
    relay_log="G:/GREYHOUND/MySQL/MySQL Server 5.1/Data/mysql-relay-bin"
    log_slave_updates=1
    skip-innodb
    innodb_additional_mem_pool_size=2M
    innodb_flush_log_at_trx_commit=1
    innodb_log_buffer_size=1M
    innodb_buffer_pool_size=8M
    innodb_log_file_size=10M
    innodb_thread_concurrency=8


    Danke! ;)

  • So, Ticket und die Logs hab ich... der Fehler bei dir hängt nicht mit dem oben aufgeführten zusammen, bei dir scheint was anderes faul zu sein.


    Wurde bei euch in der Vergangenheit durch HM oder wen auch immer mal was an der TOCR rumgeschraubt? Andere TOCR-Version? Austausch von DLL's etc?


    Ich würde mal einen Vergleich der TOCR-Dateien anstreben, evtl. liegt hier irgendwo der Hacken.


    Was war eure erste GREYHOUND-Version, weisst du das noch?

  • Servus die Herren,


    ich hatte in letzter Zeit auch immer die Log voll mit "Cannot get TOCR Status for Job 0"...Fehler aufm Server und nichts macht der GH mehr. Blöd wenn man das erst Abends merkt, warum einen keiner mit Mails nervt...


    Ich hatte das Problem immer, wenn ich per Transporter ein TIFF in den GH schicken wollte. Server abgeschmiert, nichts geht mehr - musste meinen HE Server immer neustarten.


    Ich hab jetzt einfach mal unter C:\Program Files (x86)\Transym mein gekauftes TOCR rausgehaun - dann kommt in den Logs nur kurz die Meldung "05000;2011-03-08 11:59:51,351;TOCR system ist not not available!
    " aber es funktioniert wieder alles einwandfrei. Kann wieder ohne Probleme TIFFs in den GH schicken, OCR alles wunderbar und kein Queue-Absturz mehr.


    Die Transym Version ist doch jetzt in der neuesten Version auch verbaut, wenn ich mich nicht verlesen habe oder?


    (Version 1326)