Fehlender Zeilenumbruch in HTML-Mail

  • Hallo,


    seit ein paar Tagen habe ich ein merkwürdiges Problem beim Erstellen von Emails im HTML-Format. Greyhound ignoriert hartnäckig einen Zeilenumbruch (Return) im Text. Das Problem scheint mit meinem Rechner bzw. meiner Greyhound-Installation zusammenzuhängen, denn Kollegen an anderen Rechner haben das Problem nicht und auch wenn ich per Remotedesktop mein Greyhound nutze, tritt der Fehler nicht auf.


    Der Quellcode unterscheidet sich wie folgt (Quellcode eines Kollegen):





    Quellcode meiner Mail:


    HTML
    1. <!DOCTYPE Html PUBLIC "-//W3C//DTD Html 4.01 Transitional//EN"><html><head><title></title><meta content="text/html; charset=windows-1252" http-equiv="Content-Type"><style type="text/css"><!--p { margin: 0 0 0.5em 0; padding: 0}--></style></head><body><div style="font-family: 'Tahoma'; font-size: 10.0pt" class="defaultfont"><div class="salutation">Hallo [$Item.Recipients.Firstname],</div><br>TestTest<br><br><div style="font-family: 'Tahoma'; font-size: 10pt" class="signature">



    Habe das Greyhound bereits einmal inkl. aller Daten deinstalliert und neu installiert, aber der Fehler ist geblieben.


    Hat jemand eine Idee, woran das liegen kann?


    Gruß


    Frank Schumacher

  • Hallo Frank!


    GREYHOUND nutzt für den HTML-Editor unter anderem Komponenten des Betriebssystems, vermutlich liegt hier die Ursache am installierten Internet Explorer:



    Da GREYHOUND zum Anzeigen von HTML-E-Mails den standardmässig auf jedem Windows Computer den mit installierten Internet Explorer nutzt (oder besser dessen Rendering Engine) hängt die Stabilität von GREYHOUND auch DIREKT mit der Stabilität des installierten Internet Explorers zusammen.
    Vor ein paar Monaten ist die finale Version des Internet Explorer 9 veröffentlicht worden. Unglücklicherweise ist diese Version alles andere als stabil - das Internet ist voll von Problemen. Die am häufigsten auftretenden Probleme sind dabei das immer wieder auftretende "Einfrieren des Internet Explorers für 20-30 Sekunden" sowie unmotivierte Abstürze.
    In beiden Fällen wird GREYHOUND direkt mit beeinflusst - friert der Internet Explorer 9 ein, so friert auch GREYHOUND ein, stürzt der Internet Explorer 9 ab, so zieht er auch GREYHOUND mit.
    Lösungen:
    EMPFEHLUNG: Deinstallieren des Internet Explorer 9 (in diesem Fall wird wieder der IE 8 genutzt).
    Wer den IE 9 zwingend benötigt kann folgendes versuchen:


    Wie hoffen, wir konnten hiermit ein wenig bei der Fehlersuche unterstützen.

  • Hallo Jörn,


    vielen Dank für die prompte Antwort.


    Hab e den IE9 soeben wie angegeben deinstalliert. Leider keine Änderung des Fehlers. Der Quelltext sieht immer noch gleich aus und der Zeilenumbruch wird weiter ignoriert.


    Hast du noch eine Idee?


    Gruß


    Frank Schumacher

  • Hallo,


    nachdem sich dieser Fehler nicht abstellen ließ, habe ich heute die Gelegenheit genutzt und Windows 7 Prof. 64-Bit installiert (wollte ich schon lange machen...).


    Und siehe da: Der Fehler ist weg. Wo genau es da gehakt hat, würde mich trotzdem interessieren...


    Gruß


    Frank Schumacher

  • Hallo Frank,


    ich nutze ebenfalls Win7 in der 64Bit Variante. Hast du denn den IE9 drauf? Wenn ich mich recht erinnere dann wird der IE9 erst über das Windows Update eingespielt. Zumindest ist das bei der Home Premium Variante so.


    Wenn du also nun noch den IE8 drauf hast, dann gratuliere! Ich bekomme meinen 9er nämlich auch nicht mehr ohne Neuinstallation runter von meiner Kiste und somit habe ich das Zeilenumbruchproblem auch :-(


    Lieben Gruß

  • Hallo Sascha,


    das stimmt. Den IE9 will mir Microsoft auch immer per Update "unterjubeln". Das IE9-Update habe ich jetzt erstmal ausgeblendet, kommt aber alle paar Wochen wieder hoch. Kann dann leider die Updates nicht blind durchwinken, sondern muss da etwas genauer hinschauen...


    Gruß

  • Hallo,


    zu früh gefreut :( .


    Seit gestern habe ich den gleichen Fehler wieder. Kann aber definitiv nichts mit dem IE9 zu tun haben, da ich den während des Updatens komplett verweigert habe und sich nur der IE8 auf dem Rechner befindet.


    Im Zuge weiterer Recherchen habe ich zunächst alle Office 2003 Updates (wir nutzen noch Office 2003) vom Rechner wieder deinstalliert.


    Was soll ich sagen: Jetzt funktioniert auch der Zeilenumbruch wieder so, wie es sein soll :) .


    Ich halte euch weiter auf delm Laufenden...


    Gruß