Eigene Dateien für PHP-GUI wo?

  • Ich möchte ein wenig mit der PHP-GUI experimentieren, scheitere aber schon an den Basics. Also GH bringt ja schon einen Webserver mit, den ich dafür nutzen möchte. Wo aber müssen nun PHP-Dateien liegen, damit ich die auch abrufen kann?
    Ich nehme z. B. die simple PHP-Datei test.php

    Code
    1. <?PHP
    2. phpinfo();
    3. ?>

    Diese speichere ich auf dem Server unter C:\Program Files (x86)\GREYHOUND\Server\Web\test.php und würde nun erwarten, sie mit 123.123.123.123/test.php oder auch 123.123.123.123/Web/test.php abrufen zu können (statt 123... nehme ich selbstverständlich die IP-Adresse meines eigenen GH-Servers).


    Antwort ist aber bei beiden Varianten:
    404 Not Found
    The called handler cannot be found on this server.
    GREYHOUND RPC Server 4.1.6 build 1491


    Kann mich jemand auf den rechten Pfad (im wahrsten Sinne des Wortes ;) ) führen?


    PS: Shares funktionieren, also prinzipiell läuft der interne Webserver.

  • Hallo Wolfram,


    leider scheint es nicht damit getan, dich nur "auf den richtigen Pfad" zu leiten ... - denn: http://123.123.123.123/Web/test.php sollte eigentlich genau das gewünschte Ergebnis bringen. Dass der Webserver an sich läuft, sieht man ja auch an der Fehlermeldung, die du bekommen hast, denn da steht ja: GREYHOUND RPC Server 4.1.6 build 1491. Diese Meldung wurde also vom GH-Webserver ausgegeben.


    Warum nun die phpinfo() nicht angezeigt wird, müsste man am Server selbst genauer prüfen - kann ich von hier aus nicht sagen. Ich schätze, da müsste sich dann mal jemand aus unserer Technik zu äußeren ...

  • Hallo,


    die Datei liegt im Web/ Ordner des Servers richtig, auch die URL /Web/test.php ist soweit korrekt.
    In den Einstellungen des Servers muss allerdings PHP aktiviert sein. Das kann im GREYHOUND Admin unter "Konfiguration" im Bereich "HTTP Protokoll" eingestellt werden. Dort gibt es eine Checkbox "PHP Servererweiterung verwenden", die angehakt sein muss.


    Falls beim HTTP Protokoll ein anderer HTTP-Port als 80 eingestellt ist, dann muss der Port entsprechend in der URL im Webbrowser mit angegeben werden. Läuft HTTP im GREYHOUND also auf Port 8080, so muss die URL dann http://123.123.123.123:8080/Web/test.php lauten.


    Kannst Du einmal nachsehen, ob evtl. in den Einstellungen die PHP Servererweiterung noch nicht aktiv ist?


    Grüße,
    Robert