E-Mail senden führt zu Fehler wenn Mail längere Zeit geöffnet war

  • Folgendes hatte ich nun schon mehrfach:


    1. Ich klicke Strg + R um eine Mail aus der Liste zu beantworten.
    2. Mail geht auf im Editor und ich schreibe meine Antwort, werde dann aber durch ein Telefonat unterbrochen.
    3. Keine Ahnung, welche Zeitspanne hier nun genau entscheidend ist - aber wenn ich nach ca. 1 Std. die noch offene Mail weiterschreibe und dann abschicken will, dann bekomme ich eine Fehlermeldung:
    ------------------------------
    Eingabefehler beim Ausführen von "Ursrpüngliches Element markieren"
    Unbekannte Fehlermeldung (EFbmRpcUserError, ID: 205)
    Fehlercode 205
    Missing lock (requested item with ID 44691 is not locked).
    -------------------------------


    Ob die Mail dennoch verschickt wurde, kann ich nicht genau sagen. Eine Kopie liegt in "Entwürfe" - die Orignalmail hat den kleinen Pfeil vorne und wenn ich den anklicke, dann sehe ich 2 x meine Antwort darunter. Bei den Antworten steht im Systemprotokoll jeweils:
    Das Element wurde gerendert.
    Das Element wurde erstellt.


    Irgendwie scheint es da zu einem Timeout zu kommen, so dass der GH-Client nicht mehr in der Lage ist, die Markierung des ursprünglichen Elements zu ändern.

  • Hallo,


    hier mal eine Gedächtnisstütze: Mail kann nicht verschickt werden - Fehlercode 205


    Sie hatten das Problem bereits gemeldet. Leider ist bis dato die genaue Fehlerursache nicht bekannt.


    Es kann übrigens auch zu dem Problem kommen, wenn die Verbindung zum GREYHOUND Server kurzzeitig unterbrochen war (z.B. WLAN Verbindungen, UMTS, DSL-Ausfall, etc.). Ohne die genauen Umstände ist das Problem schwierig zu lösen.


    Die größte Gefahr besteht zur Zeit darin, dass eine E-Mail doppelt beantwortet wird. Die E-Mail wird in dem Fall übrigens verschickt, nur die Markierung für das ursprüngliche Element kann nicht aufgehoben werden.

  • Hallo,


    hier mal eine Gedächtnisstütze: Mail kann nicht verschickt werden - Fehlercode 205


    Danke, danke - kann so ein alter Mann wie ich immr gebrauchen ...


    Zitat

    Sie hatten das Problem bereits gemeldet.


    Tatsächlich? - Ich hatte den Eindruck, dass ich dieses Problem so noch nicht gemeldet hatte ... - aber wie gesagt: ich werde alt ...
    Neu erscheint mir hier jedoch die Info, dass sich dieser Effekt reproduzieren lässt, wenn man die besagte Mail nur lange genug geöffnet lässt. Diesen Umstand hatte ich - wenn mich meine vergrauten Zellen nicht erneut täuschen - in dem von Ihnen genannten Beitrag nicht genannt, weshalb mir auch nicht bewusst war, dass es sich hier möglicherweise um dieselbe Ursache handelt, zumal die Wirkung doch eine andere zu sein scheint ... Denn HIER ging es um ein sporadisch auftretendes Problem, bei dem der Zeitfaktor überhaupt keine Rolle spielte.


    Zitat


    Leider ist bis dato die genaue Fehlerursache nicht bekannt.


    Das ist bedauerlich - aber eben drum hoffte ich ja mit meinem jetzigen Beitrag nicht nur eine "Gedankenstütze" zu provizieren, sondern ggf. eine zusätzliche Information liefern zu können (Zeitverzögerung ...), die die Ursachenforschung möglicherweise vereinfacht.


    Zitat


    Es kann übrigens auch zu dem Problem kommen, wenn die Verbindung zum GREYHOUND Server kurzzeitig unterbrochen war (z.B. WLAN Verbindungen, UMTS, DSL-Ausfall, etc.). Ohne die genauen Umstände ist das Problem schwierig zu lösen.


    Kann ich alles ausschließen. - Wie gesagt: es scheint irgendein Timeout zu greifen. Oder aber der GH verliert selbst aus irgendeinem Grund die Verbindung. Netzverbindung war jedenfalls permanent vorhanden - definitiv.


    Zitat


    Die größte Gefahr besteht zur Zeit darin, dass eine E-Mail doppelt beantwortet wird. Die E-Mail wird in dem Fall übrigens verschickt, nur die Markierung für das ursprüngliche Element kann nicht aufgehoben werden.


    Die größte Last besteht zur Zeit darin, dass man sich nie 100%ig sicher sein kann, ob die Mail nun verschickt wurde oder nicht. - Ich konnte die Mail nämlich vorhin weder im Postausgang noch im Gesendet- oder Erledigt-Ordner finden ... - und habe sie daher zur Sicherheit nochmals verschickt.
    Fakt ist, dass sowas unnötig aufhält und die Arbeit nicht erleichtert ...


    So - und nu lass ich mich von meinem Zivi wieder auf's Zimmer rollen ...



    ;)

  • Hallo,


    der fehler tritt bei uns auch weiterhin auf. Wir haben Kabel-LAN und keine Ausfälle. Auch bei uns tritt der Fehler nur auf, wenn man nbe Zeit lang in der Mail rumspielt bzw. währendessen andere GH-Tabs öffnet (z.B. Suche etc.). 60 Minuten warten ist nicht nötig, reichen i.d.R. auch 5, wenn man ordentlich Zeugs währendessen macht (Suche, Kalender, etc.).

  • Hallo,


    ich glaube der Hinweis mit dem "wenn man richtig viel macht" könnte in die richtige Richtung führen. An dieser Stelle habe ich bisher noch garnicht gesucht. GREYHOUND verwendet standardmäßig 4 gleichzeitige Verbindungen zum Server. Wenn man extrem viel hin und her wechselt, kann es passieren, dass die aktuelle Verbindung zum Abbrechen einer Funktion geschlossen wird. Passiert dies mit der einzigen offenen Verbindung, könnte es sein, dass der Server den Benutzer kurzzeitig als nicht mehr eingeloggt wertet und deshalb sämtliche Sperren des Benutzers freigibt.


    Danke für den Hinweis.

  • Das Problem triit bei mir gelegentlich auf, wenn der übereifrige Virenscanner Avira sich in die Leitung klinkt und Datenpaket durchsuchen will. Man kann dann mittels Etherael sehen, dass manchmal die verwendeten Ports kurzzeitig "weg" sind, trotz guter Netzwerkverbindungen. Ich habe Greyhound ausgeschlossen, seither tritt das nicht mehr auf.


    Vielleicht kann man das Timeout beim Greyhound höher setzen, um ihn toleranter gegen kurzzeitige Aussetzer zu machen?

  • Hallo,


    wollte nur mitteilen, dass ich das Problem hier auch des Öfteren haben. Netzwerkprobleme kann ich ausschließen, und einen Timeout auch. Als Virenscanner haben wir AVK von GData laufen, der aber meines Wissens nach keine Ports scannt. Ich werde auch mal darauf achten ob es was mit der Anzahl der Verbindungen im Zusammenhang dem Wechseln von Tabs o.Ä. zu tun haben könnte.


    Lieben Gruß

  • Hallo Sascha,


    wie im Changelog von BUILD 814 beschrieben, wurde die zugrundeliegende Ursache gefunden und behoben. Nur in absoluten Ausnahmesituationen (GREYHOUND wird via hackeligem GPRS betrieben) oder einem wildgewordenen Virenscanner sollte diese Fehlermeldung noch auftreten. Wenn Ihr also BUILD 840 einsetzt und diese Fehlermeldung häufiger auftritt tippe ich auf Virenscanner. Vielleicht gibt es im GData Virenscanner eine Möglichkeit Programme von Scan auszuschliessen.


    Beste Grüße
    hildebrand

  • wie im Changelog von BUILD 814 beschrieben, wurde die zugrundeliegende Ursache gefunden und behoben. Nur in absoluten Ausnahmesituationen (GREYHOUND wird via hackeligem GPRS betrieben) oder einem wildgewordenen Virenscanner sollte diese Fehlermeldung noch auftreten. Wenn Ihr also BUILD 840 einsetzt und diese Fehlermeldung häufiger auftritt tippe ich auf Virenscanner. Vielleicht gibt es im GData Virenscanner eine Möglichkeit Programme von Scan auszuschliessen.


    Hallo Hildebrand,


    ok. Das das im Changelog steht hatte ich nicht zur Kenntnis genommen. Ich habe jetzt im AVK (Client) für alle Greyhound Prozesse und zusätzlich für das gesamte Greyhound Verzeichnis (auch Client) eine Ausnahmeregel erstellt. Mal sehen ob sich was ändert.


    Lieben Gruß