Nachrichten hängen im Postausgang

  • Gestern und heute hatten wir den Fall, dass alle Nachrichten im Postausgang hängen bleiben.
    Im GH-Admin unter Service-Control steht die Meldung "GREYHOUND Server hat einen Fehler festgestellt (Queue Server)".


    Nach einem Neustart des GH-Servers über den GH-Admin gehen die Nachrichten raus.


    Hier mal ein Auszug aus den Logeinträgen von heute (Das Problem trat ab ca. 9:30 Uhr auf):


    00028;2010-01-05 10:34:32,132;Cannot send message (i_id = 952499), error: Read Timeout
    00018;2010-01-05 10:34:27,031;User "9A697BA2FDF740C56B2CB406EBB1A18D-weimar": Locked by another user (requested item with ID 952502 is locked by "system").
    00018;2010-01-05 10:18:09,098;User "9D34C83F53AF3E151538581120007017-vay": Socket Error # 10053
    00018;2010-01-05 10:18:09,098;Software caused connection abort.
    00018;2010-01-05 09:39:54,385;User "9D34C83F53AF3E151538581120007017-vay": Invalid e-mail address "Anmeldeformulare" (does not contain "@").
    00018;2010-01-05 09:39:49,128;User "9D34C83F53AF3E151538581120007017-vay": Invalid e-mail address "Anmeldeformulare" (does not contain "@").
    00018;2010-01-05 09:35:29,294;User "721FF459A2F399472FAFFFF11CC3D7A0-schwab": No access to group "Jenny_Hachmeister" (User: "schwab").
    00028;2010-01-05 09:01:27,816;Cannot send message (i_id = 951219), error: Read Timeout
    00018;2010-01-05 09:01:25,492;User "4BAB887730F4FC846E1A212123658876-eidenmueller": Locked by another user (requested item with ID 951219 is locked by "system").
    00028;2010-01-05 09:00:03,482;Cannot send message (i_id = 951219), error: Read Timeout
    00018;2010-01-05 08:59:41,767;User "1C6E31AA3C38270CFE9BC2577DC43E6A-hachmeister": Invalid e-mail address "anne-kathrin.hornig" (does not contain "@").

  • Hallo,


    wir konnten das Problem leider bisher nicht lokalisieren. Können Sie einmal schauen, ob zu diesem Zeitpunkt im Task-Manager das Programm tesseract.exe, tocr.exe, avcls.exe oder at2cmd.exe zu finden ist? Bitte schauen Sie sich die Prozessorauslastung der o.g. Prozesse und von der GreyhoundServer.exe an. Ein Screenshot des Task-Managers (Prozesse) wäre hier sehr hilfreich.

  • [Build 1000] Nachdem es nun eine Weile lief, haben wir seit ca. einer Woche dieses Problem wieder mehrmals täglich. GreyhoundServer.exe hat 13% CPU, sonst sind keine auffälligen Prozesse zu sehen. Im Client kann ich unter Funktionen->Queuestatus sehen, wie immer mehr Mails auf die Verarbeitung warten. Die Mails wurden vom Mailserver abgeholt, sind aber im GH nirgends zu finden. Der Postausgang füllt sich auch zusehends :(

  • Moin Guido,


    ich vermute das dieses Problem durch eine Unregelmässigkeit beim Serverbetrieb verursacht worden sein könnte. Bitte schau einmal in die Windows Logfiles des Servers - vielleicht gibt es hier irgendeinen weiterführenden Hinweis (Reboot, Absturz etc.).. Vielen Dank!


    Beste Grüße
    hildebrand


    P.S. Der Betrieb von GREYHOUND bei HostEurope ist leider in letzter Zeit nicht ganz problemfrei: [Build 1181] Probleme und Fehler durch nicht ordnungsgemässen Serverbetrieb

  • Hallo!


    Das muss ansteckend sein ... bei ist das am 2.11. Mittags ERSTMALS passiert ... die user melden "kommt nichts mehr rein ..." - es ging aber auch nichts mehr raus.


    Sofort zum Server ... nichts im Log zu sehen ... aber bei Status auch die Meldung "GREYHOUND Server hat einen Fehler festgestellt (Queue Server)".


    Dann "Server beenden" ... dauerte so lang, dass sich den Admin einfach zu gemacht habe ... Server Neustart = alles gut, alle Nachrichten (auch Faxe) kamen dann nach und nach rein.


    Zeitgesteuerte Regeln haben wir NICHT.


    Server-OS: Windows 2008 Server 64bit

  • Guten Abend Ralf,


    mit an Sicherheit grenzender Wahrscheinlichkeit hat sich Dein GREYHOUND hier an einer E-Mail verschluckt - zu 99,99% irgendwelche extrem fies codierten SPAM-Mails / Viren. Die Fehlermeldung lautet dann im GH Admin in etwa das ein Problem im Qeueserver festgestellt wurde. Stoppt man GREYHOUND nun und startet ihn neu, so wird die steckengebliebene E-Mail verworfen und es wird mit der nächsten E-Mail weitergemacht. Wenn man nicht das Pech hat, mehrere "schlechte E-Mails" am Stück zu haben, läuft dann wieder alles problemlos.


    In einem solchen Fall wäre es natürlich klasse, wenn Ihr uns kurz informiert (und den GREYHOUND Server NICHT neu startet), da wir die zugrundeliegende "schlechte E-Mail" gerne analysieren würden um das Problem bei der Wurzel zu packen!


    Beste Grüße
    hildebrand

  • Zitat

    Das muss ansteckend sein ...

    Haha, aber echt! Bei uns seit Montag auch wieder das selbe Problem. Mehrmals täglich kommt die Queueserver-Meldung. Ich starte bisher auch immer neu (Server stoppen dauert ca. 1/4 Stunde).


    @Hildebrand: habe zuletzt die Pixi-kontakte in den GH geholt und wir haben mittlerweile um die 100 Gig Daten auf interner DB laufen ... Werde beim nächsten mal Info geben, damit ihr euch das mal anschauen könnt.


    @Guido, @Ralf: Habt ihr unter Funktionen->Queuestatus irgendwelche wartenden Elemente (die auch nach Neustart immer weiter warten)? Ist bei uns nämlich der Fall.

  • Hallo Locke,


    bitte gib doch ein Support-Ticket auf und lass uns dabei Folgendes wissen:


    a) Setzt Ihr pixi ein?
    b) Wo wird Euer GREYHOUND betrieben, bei uns im RZ oder bei Euch?
    c) Seit wann tritt das Problem auf?
    d) Habt Ihr eventuell neue Regeln erstellt, bevor das Problem aufgetreten ist?


    Vielen Dank und Beste Grüße
    hildebrand

  • Hallo,
    nein wir setzen nicht pixi ein.
    wir haben einen eigenen Server Windows 2008 R2 64 Bit Server ist 2 x Quadcore Xeon + 12 GB Ram.
    Version ist 4.0.0 1274
    Problem tritt ungefähr seit einer Woche auf.
    Unser email Postfach ist umgezogen auf einen anderen Server. Wurde aber auch in den POP und Smtp einstellungen geändert.
    LG

  • Hallo,


    nach eingehender Analyse des Problems bei einem anderen Kunden sind wir der Ursache auf die Spur gekommen. In ganz bestimmten "unglücklichen Konstellationen" können nicht richtig codierte E-Mails (in der Regel SPAM-E-Mails) die FUZZY-Checksum Berechnung im GREYHOUND Spam-Filter extrem lange und intensiv (5-15 Minuten pro E-Mail) beschäftigen. Die betroffenen E-Mails werden zuverlässig verarbeitet - es braucht aber im Worst-Case bis zu 15 Minuten bis EINE EINZELNE falsch codierte E-Mail verarbeitet ist - während der Verarbeitung steigt die Prozessorlast rapide an. Man kann die Meldung des FBM-Admins "GREYHOUND Server hat einen Fehler festgestellt: Queserver" getrost ignorieren - der reagiert noch, ist aber extrem beschäftigt.


    Mit dem nächsten Betarelease haben wir die Fuzzy-Checksum-Berechnung nochmals weiter optimiert. Die E-Mails, die heute so lange für die Verarbeitung benötigen, werden dann um den Faktor 5-10.000 schneller verarbeitet.


    Bis dahin kann man die Fuzzy-Checksum Berechnung im GREYHOUND Admin einfach deaktivieren. Nach dem Deaktivieren den GREYHOUND Dienst bitte einmal Stoppen und wieder Starten damit die Änderung aktiv wird.


    Beste Grüße
    hildebrand