gescannte Unterschrift und Stempel mit schwarzem Balken

  • Ich habe heute endlich mal erste Versuche unternommen, auch anderen Schriftverkehr - außer Email - mit dem GH abzuwickeln. Als erstes wollte ich eine Auftragsbestätigung, die ich als PDF bekommen hatte, mit Stempel und Unterschrift versehen und dann zurückfaxen. So weit so gut ...


    Also Stempel gescannt, Unterschrift gescannt, eingebunden. Alles super. Im Entwurf bei mir lokal sah das alles prima aus. Ich hab dann - weil ich neugierig war - das Fax auch noch mal an mich selbst geschickt. Und als ich das Ergebnis sah, war ich doch sehr ernüchtert. ;( - Mein Stempel und meine Unterschrift sahen nämlich so aus:



    (bei der Unterschrift genau so ein hässlicher schwarzer Balken links)
    Kaum hatte ich mir das angesehen, rief auch schon der Geschäftspartner an und meinte, ich solle ihm das Fax bitte noch mal schicken, das sei kaum zu lesen ...


    Woran liegt das? Mache ich was falsch?
    Die Bilder waren gescannt mit 300dpi, Farbe auf schwarz gesetzt, gespeichert wurden sie als transparente PNGs. Und wie gesagt: lokal sah das alles gut aus ...


    Please help! ?(

  • Wir wir gerade ja schon lokalisiert haben, liegt es vermutlich am .png Format. Was mir dabei einfällt: Den Stempel brauchste ja eigentlich nicht scannen, der müsste doch als .eps etc. vorliegen (weil der Stempel musste ja mal erstellt werden) und daraus kann man dann doch ein sauberes Bild zaubern...

  • Hallo,


    ich habe das Problem in den internen Bug-Tracker aufgenommen.


    Können Sie uns bitte den Firmenstempel als PNG-Grafik (so wie Sie ihn eingefügt haben) zukommen lassen, damit wir das Problem besser nachstellen können?



    Klar, gerne. An welche Adresse ging das noch gleich?

  • Hallo,


    das Problem hängt höchstwahrscheinlich mit der verwendeten gdiplus.dll auf der Serverseite zusammen. Das Problem konnte bei einem weiteren Kunden dadurch gelöst werden, dass eine neuere Version der gdiplus.dll auf dem Greyhound Server installiert worden ist.


    Zukünftig planen wir, eine aktuelle gdiplus.dll im Anwendungsverzeichnis des Clients bzw. des Server mitzuliefern.

  • Hallo Tobias,


    danke für den Hinweis. - Ich habe mir jetzt mal eine neuere gdiplus.dll besorgt. Nur, was mach ich nun damit?? - Ich habe mal den Server durchsucht und ich finde gleich 8 Ordner, in denen jeweils eine Gdiplus.dll schlummert ... ?(
    Das sind dann so Verzeichnisse, die heißen z. B.: x86_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.6002.18005_none_8da2227b631d87ae und liegen alle in c:\Windows\winsxs\


    Also wohin mit der neuen gdiplus.dll?

  • Hmmm ... nicht wirklich. Da lädt man ein selfextracting archive runter - und wenn man das entpackt bekommt man 2 Verzeichnisse, wo wiederum nicht klar ist, wo die nun hin sollen ... *kopfkratz*.


    Könntet ihr evtl. bei dem genannten Kunden noch mal nachfragen, was genau die da gemacht haben? Ich würde nämlich gerne für Stempel und Unterschrift transparente PNGs nutzen.

  • Hallo Andreas,


    ich hab den Beitrag nur kurz überflogen. Ich hatte auch Probleme mit meiner Unterschrift als PNG mit Transparenz. Lösen konnte ich das durch ein geringes skalieren auf 500px in der Höhe (obwohl eigentlich 512 erlaubt sind). Für die Erzeugung habe ich Photoshop CS4 mit "Für Web und Geräte speichern" verwendet (ohne Interlacing Option). Aus anderen Anwendungen weiß ich, das PNG nicht immer gleich PNG ist, daher schreibe ich das so ausführlich.


    Lieben Gruß

  • Hallo Sascha,


    jo, den Tipp mit PNG und PNG24 und so, den hatte mir ein Kollege auch schon gegeben. Half aber leider nicht.
    Angeblich sollte ja in der aktuellen Release da nun was geändert worden sein. Aber ich habe gerade getestet und leider sind wieder sämtliche von mir eingefügten Elemente mit dem schwarzen Balken versehen.


    Das betrifft übrigens nicht nur die Scans und PNGs - ich hatte auf dem Fax auch einen Textblock eingefügt und selbst dieser hat den fetten schwarzen Balken links.


    Evtl. liegts ja wirklich an dieser veralteten Libary .. - aber noch hat mir niemand sagen können, wie ich die aktualisieren kann. :?:

  • Hallo,


    das mitliefern einer passenden GDIPlus führt leider zu ganz neuen Problemen, welche wir nicht vorhersehen konnten. Aktuelle GDI-Plus Versionen haben das Problem mit dem schwarzen Balken aber definitiv nicht mehr. Um das Problem zu beheben, muss also eine neue GDI-Plus Version auf dem System installiert werden. Leider kann ich aktuell die Installationspakete von Microsoft zu diesem Thema auch nicht finden.

  • Als an dem Punkt verzweifel ich noch ... ?(


    Ich hab jetzt mal eine vo MS heruntergeladene gdiplus.dll sowohl ins GH-Verzeichnis (Server) als auch ins System32 gelegt - leider ohne Erfolg. Ich hatte übrigens vorher überhaupt keine gdiplus.dll auf dem Server (Win2008).


    Hat denn irgendjemand transparente PNGs als Stempel und Unterschrift funktionsfähig laufen im GH?

  • Hallo Andreas,


    bei uns klappt alles prima. Ich habe es gerade noch einmal ausprobiert: Neues Fax mit unserer Vorlage erstellt, Signatur eingefügt (Button "Unterschrift") und verschickt. Es kommt alles einwandfrei an.


    Mit der GDIPlus-Datei habe ich mich noch nie beschäftiigen müssen, weder auf Server noch auf meinem Client. Der GH-Server läuft bei uns auf einem voll gepatchten SBS2003. Ich habe einen Windows 7 64Bit Rechner.


    Was meinst du mit "als Stempel und als Unterschrift"?


    Lieben Gruß

  • Moin Sascha,



    bei uns klappt alles prima. Ich habe es gerade noch einmal ausprobiert: Neues Fax mit unserer Vorlage erstellt, Signatur eingefügt (Button "Unterschrift") und verschickt. Es kommt alles einwandfrei an.


    Das freut mich für euch ... - bei uns leider - noch - nicht. Und ihr benutzt auch transparente PNGs?


    Zitat


    Ich habe einen Windows 7 64Bit Rechner.


    Ähem .. Frage an @digitalguru: Das mit der gdiplus, das bezog sich doch auf den Server? Oder? - Also am Client hatte ich jetzt nix gemacht ... - Ich nutze ein WinXP SP3, das sich allerdings seit geraumer Zeit weigert, weitere patches zu installieren. Die Tage von der Kiste sind aber gezählt - es stehen hier bereits nagelneue Workstations mit Win 7 drauf, die in den nächsten Tagen zum Einsatz kommen werden.
    Sollte es am Ende am Client liegen? Und mit Win 7 ggf. dann erledigt sein?? *hoff*


    Zitat


    Was meinst du mit "als Stempel und als Unterschrift"?


    Nun ja, ich habe insgesamt 3 PNGs angelegt:
    - Unterschrift
    - Stempel
    - Stempel UND Unterschrift (wäre übrigens klasse, wenn man im GH auch genau alle 3 Kombinationen hinterlegen könnte! ;) )


    Die Unterschrift ist direkt beim Benutzer hinterlegt - der Rest als Grafik auf der lokalen Platte. Wenn nur Unterschrift benöntigt wird, nehm ich den Button "Unterschrift" - ansonsten füge ich das als Grafik ein.


    Schönen Tag wünsche ich! - Mit wenig abgeschnittenen Krawatten, Schnürsenkeln oder sonst was ... :)

  • Ähem .... - was soll ich sagen .. - nu geht's! :-)


    Zitat

    hattest du den Server (die Hardware) danach mal neu gestartet?


    Nee, hatte ich nicht - aber jetzt! ;)
    Ich hatte zwar den GH-Server neugestartet, aber nicht den die Win-Kiste an sich. Hatte gestern abend eine aktuelle gdiplus.dll sowohl ins GH-Server-Verzeichnis als auch ins System32 geschmissen - und eine davon scheint nun zu wirken. *freu*


    ABER:
    Eins macht mich aber dennoch stutzig: Ich sehe jetzt auch die ganzen Textfaxe der letzten Tage - die alle diesen schwarzen Balken hatten - OHNE den Balken! ?(
    Warum macht mich das stutzig: nun - ich hatte auch Torsten mal so'n Testfax geschickt - und bei dem war AUCH der schwarze Balken drauf. Ich dachte, wenn der Balken einmal drauf ist, dann issa drauf ... nun issa aber bei den EMPFANGENEN Testfaxen nicht mehr drauf ... ?( Kann ich grad irgendwie nicht nachvollziehen ...


    Hmm ... - aber egal: hauptsache es funkt jetzt! - Toooooooorsssstttteeeeeeeen ... ich muss dir gleich noch mal ein paar Faxen machen ... ^^