Datumsanzeige ändert sich

  • Seit dem vorletzten Update beobachte ich, dass hin und wieder das Datum in der "Datum von" Spalte plötzlich im amerikanischen bzw. englischen Format erscheint. Auf dem Server wurde nichts an den Einstellungen geändert. Das war zuletzt immer wieder mal kurzzeitig der Fall - und dann auf einmal wieder weg.


    Seit dem Update heute morgen war es dann nicht mehr aufgetreten und ich dachte schon, das sei nun gefixt. Aber seit 5 min. habe ich es wieder - und mein Kollege auf seinem Rechner auch.


    Wir haben am Wochenende hier auf Windows 7 umgestellt - kann es evtl. irgendwas damit zu tun haben?

  • So - weil die Sache mit dem Datum echt nervt, habe ich da nun noch mal genauer recherchiert:


    Es liegt definitiv nicht an irgendeiner Einstellung auf dem Server - da ist alles okay.
    Man kann - zumindest bei uns - folgendes Verhalten jederzeit reproduzieren:


    1. Client starten - Datum erscheint überall in der Form: MM/TT/YYYY H:MM:SS AM/PM
    2. im Client die Sprache (unter "Einstellungen") einmal auf Englisch wechseln - und dann wieder zurück auf Deutsch. Datum erscheint nun überall in der Form: TT.MM.YYYY HH:MM:SS
    3. Client schließen und erneut öffnen - Datum ist wieder englisch. :(


    Das passiert nur auf unseren Win 7 Rechnern. Auf den XP-Kisten ist alles in Ordnung.
    Das riecht nach irgendeinem Rechte-Problem, durch das Einstellungen nicht dauerhaft gespeichert werden können. Allerdings habe ich mir die ini-Dateien in C:\Benutzer\a.ziethen\AppData\Roaming\GREYHOUND\C-Greyhound angesehen: die sehen okay aus und tragen auch ein aktuelles Datum. Wird sonst noch wo was gespeichert?


    Wie ich gerade feststellen konnte lässt sich das Ganze übrigens bereits mit den Spracheinstellungen in der Anmeldebox genau so reproduzieren.


    Help needed! ;(

  • Client geschlossen, Desktop.ini umbenannt, Client geöffnet: engl. Datum.
    Sprache auf Englisch - und wieder zurück auf Deutsch: deutsches Datum.
    Client geschlossen - Desktop.ini wurde neu angelegt.
    Client erneut geöffnet: wieder engl. Datum.


    Desktop.ini sieht aus wie folgt:


    Schreiben scheint dann also nicht das Problem zu sein - sondern eher das Lesen. Wobei alle anderen Inhalte der Desktop.ini ja korrekt verarbeiteet werden (Fensterposition etc.).

  • Ich muss das noch mal hochzhiehen, weil es bei uns mittlerweile doch zu größeren Problemen führt, z. B. ist nun schon mehrfach beim Anlegen von Aufgaben der GH abgeschmiert (mit Debug-Bericht im Hintergrund) beim Eintragen eines Datums. Denn, auch wenn man wie oben beschrieben die Sprachen wechselt und dann in den Listen wieder das korrekte deutsche Datum hat, steht an vielen anderen Stellen - z. B. bei den Aufgaben und Terminen - in den Datumsfeldern immer noch das Datum im engl. Format.


    Und bei Versuchen, da was zu ändern schmiert der Client dann hin und wieder ab.
    Wenn ich z. B. ein so ein Datumsfeld "Au" eintrage und mit TAB weitergehe, dann wird auf "Aug/" vervollständigt und der GH verabschiedet sich mit folgender Meldung:


    Unbekannter Fehler
    Bei der Durchführung der gewünschten Aktion ist ein Fehler aufgetreten. Falls der Fehler erneut auftritt ....
    Invalid Date.


    Und dann die üblichen Optionen: neu starten, beenden, für 60 sec. fortsetzen.



    Hat irgendjemand eine Idee woran das liegen kann? Auf unseren XP-Kisten funktioniert alles einwandfrei, das Problem tritt nur auf den Win 7 -Rechnern auf.

  • Hallo,


    das Datumsfeld akzeptiert eigentlich nur Zahlen und Punkte. Wie kann man dort überhaupt "Au" eintragen? bei mir funktioniert dies nicht. Getestet unter Windows 7 Ultimate 64-Bit.


    Der interne "Exception-Handler" von GREYHOUND ist hier etwas übereifrig. Ein ungültiges Datum sollte dem Benutzer höchstens eine kleine Fehlermeldung anzeigen und dann die erneute Eingabe ermöglichen. Aber das ganze befindet sich bereits im internen Bug-Tracker und wir kümmern uns um das Problem.


    Das das Datum immer wieder Englisch ist, kann ich übrigens nach wie vor nicht nachstellen. Im GREYHOUND Admin ist als Sprache auch wirklich "Deutsch" eingestellt?

  • Hier noch mal die komplette Dokumentation des Ganzen:


    1. Servereinstellungen:


    2. Datumsanzeige in den Listen nach Clientstart


    3. aktuelle Spracheinstellung im Client


    4. Änderung der Client-Sprache auf Englisch - und wieder zurück auf Deutsch


    5. Datumsanzeige in den Listen nach o. g. Sprachwechsel im Client und Wechsel der Nachrichtengruppe



    (Forsetzung folgt .... - da nur 5 Attachments hier möglich sind)

  • 6. Datumsanzeige bei Erstellen einer Aufgabe


    7. Eingabe eines Buchstabens "A" in ein Datumsfeld


    8. Eingabe eines zweiten Buchstabens "u" mit Autovervollständigung auf "Aug/"



    Tritt bei uns wie gesagt auf 2 Rechnern auf. Wer nutzt denn hier sonst noch Win 7? Ich kann mir nicht vorstellen, dass es sich hier um ein lokales Problem handelt ... - Bitte um Hilfe.

  • Hallo,


    steht der Rechner was die lokalen Systemeinstellungen angeht auf Deutsch? Natürlich sollte diese Einstellung GREYHOUND nicht beeinflussen, allerdings wäre es sehr hilfreich zu wissen, um das Problem besser lokalisieren zu können.


    Ich kann übrigens nach wie vor nicht "Au" in Datumsfelder eintippen. Wichtig wäre erstmal, dass GREYHOUND überhaupt immer ein deutsches Datum anzeigt.