Fehler bei automatisch generierter Anrede

  • Ich hatte jetzt schon zum zweiten Mal den Effekt, dass die Mail, die ich tatsächlich verschickt habe, eine falsche Anrede bekommen hatte.


    Folgendes Szenario:
    Ich habe drei Kontakte, bei denen die Anreden wie folgt konfiguriert sind:
    Kontakt 1: Michael Meier, Anrede: "Hallo [$Recipient.Firstname]"
    Kontakt 2: Gabi Müller, Anrede: "Hallo [$Recipient.Firstname]"
    Kontakt 3: Sabine Schmidt, Anrede: "Hallo Frau [$Recipient.Lastname]"


    Ich schreibe eine Mail an Kontakt 3 und setze Kontakt 1 und Kontakt 2 in CC (in genau dieser Reihenfolge).
    Eigentlich müsste die Anrede nun lauten: "Hallo Frau Schmidt". Stattdessen steht in der Mail: "Hallo Sabine" (war in diesem Fall besonders unangenehm :( ).


    Zweiter Fall: Ich schreibe an Kontakt 1 und in CC sind Kontakt 2 und Kontakt 3.
    Eigentlich müsste die Anrede lauten: "Hallo Michael" - da steht aber: "Hallo Gabi" .


    Es sieht also so aus, als wenn der Hund die Form der Anrede zwar auf Basis des Empfängers nimmt, den Namen aber aus dem ersten Kontakt in CC nimmt.

  • das problem besteht aber schon länger - ich hatte es damals auf eigene Dummheit geschoben.
    Ich hatte Reply an Kundin und BCC meinen Außendienstler, da es um eine Reklamation ging - die Kundin hat die Mail mit Hallo Herr ... (Namen Außendienstler) erhalten. Habs aber auch versäumt mir die Vorschau anzusehen.


    Ich finde auch, daß die Anreden grundsätzlich auf den Empfänger gepolt sein sollten und nicht auf die CC oder BCC

  • Hallo,


    das Problem entsteht durch mehrere klassifizierte Kontakte. Der Text des Elements kann ja immer nur persönlich für einen Empfänger sein und wird nicht mehrfach generiert. Es werden nun 3 Empfänger eingefügt, welche klassifiziert sind. Das System holt sich nun den ersten Empfänger (welcher nicht unbedingt der erste sein muss, welcher eingefügt wurde) und bereitet den Text für diesen Empfänger zu. Aktuell besteht keine Relation zwischen einer Adresse und der Kontaktklassifizierung. Das System weiß nach dem versenden (also nachdem im GREYHOUND Client auf Senden gedrückt wurde) nicht mehr, welcher klassifizierte Kontakt zu einer Adresse gehört. Normalerweise ist diese Relation auch nicht wichtig, an dieser Stelle bekommt sie allerdings erhöhte Relevanz.


    Ich habe das Problem in den internen Bug-Tracker aufgenommen.

  • Sorry, aber das kann ich nicht ganz nachvollziehen. Wenn ich doch ne Mail an X schreibt und ich habe Y + Z im CC: , dann MUSS der GH doch den Text auf Basis von X "zubereiten" und darf nicht auf Y oder Z zugreifen.
    Es sind doch hier verschiedene Felder und nicht etwa mehrere Empfänger im "To:"-Feld.